I think I’ve seen this message on EVERY local Exchange to Office 365 migration during the Hybrid Configuration process. Fails trying to get federation information from the local Exchange server. If you prep the wizard by manually running the command, it seems to go through.

First off, make sure you have a wildcard certificate – Microsoft tries to connect to https://autodiscover.yourdomain.com to get the federation information, so you need to have a certificate that will work for that address.

Then, I’ve had several start working by running Get-FederationInformation from a Remote Office365 Powershell manually – (what the wizard is trying to do) and then finishing the wizard right afterwards, like this:

  1. Get your Manage Hybrid Configuration to the last step where it is ready to do it’s thing.
  2. Open a Power Shell prompt and run
    $UserCredential = Get-Credential
  3. Fill out your Office 365 Admin credentials and hit enter
  4. Now in the Power Shell run
    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $UserCredential -Authentication Basic -AllowRedirection
  5. Finally run
    Import-PSSession $Session
  6. You should now be connected to Office365, so run
    Get-FederationInformation -DomainName yourdomainname
  7. Office365 will try to connect to autodiscover.yourdomainname.com to grab the federation info, if it fails, check out some of these things. If it succeeeds, leave this open and go back and hit the “next” button on your Hybrid configuration wizard. It’ll fail again, but this time trying to setup the hybrid mail flow connector, just hit back and then next again and it should FINISH sucessfully!

 

LEAVE A REPLY

Please enter your comment!
Please enter your name here